This project is read-only.

Event logging set to level 0. (filling the event log)

Nov 28, 2012 at 7:16 AM

Hi,

 

i installed the agent, since then my event log (application log) filling up with:

event id 0

source: RoutingRuleAgent

message: Event logging set to level 0.

the redeem is around 4 events in a one second.

OS: Win2008R2 SP1

Exchange 2010 SP2 RU2

Used DLL from the downloads for Exchange 2010 SP2.

Nov 28, 2012 at 3:16 PM

Hi,

 

i tried to recompile it with my binaries ... but same result, i saw in the code, how can i mange it? :( :

 // Read EventLogLevel from Registry (this gets called with each new instance, a little unnecessary)
            this.eventLogRegKey = Registry.LocalMachine.OpenSubKey("System\\CurrentControlSet\\Services\\MSExchangeRoutingRuleAgent\\Diagnostics");

            if (this.eventLogRegKey != null)
            {
                if (eventLogRegKey.GetValue("General") != null)
                {
                    this.eventLogLevel = ((int)eventLogRegKey.GetValue("General"));

                    EventLog.WriteEntry("RoutingRuleAgent", "Event logging set to level " + this.eventLogLevel.ToString() + ".");
                }
                else
                {
                    // this could be used at a later date for adding necessary logging entries or alternate logging.  For now we'll use the .NET installer defined above (installutil.exe).
                }
            }

Nov 29, 2012 at 8:12 AM

Exception (OnRouted): The message has been deferred.
   at Microsoft.Exchange.Transport.TransportMailItemWrapper.ThrowIfDeferred()
   at Microsoft.Exchange.Transport.TransportMailItemWrapper.get_Message()
   at RoutingRuleAgent.RoutingRuleAgent.RoutingRuleAgent_OnRoutedMessage(RoutedMessageEventSource source, QueuedMessageEventArgs e)

Also.. the agent seem not responding well :(

Dec 5, 2012 at 5:28 PM

you need to turn off the diagnostics to stop the event log entries. 

\\HKLM\System\\CurrentControlSet\\Services\\MSExchangeRoutingRuleAgent\\Diagnostics\\

Delete the General key and that should do the trick.  You shouldn't have to do a restart from what I've seen.

Dec 12, 2012 at 8:30 AM
Hi Jreed,

Thanks!, perhaps you can assist again with the question:
The reason i want to use the DLL is to point out to send connector that use MX DNS and not smarthost, but i get DNS error every time ... i tried to add to the address space (for test!) regular domain it work fine! i double check all dns configuration ..

it seems the message been resubmit to the queue without the DNS part???

Thanks



From: [email removed]
To: [email removed]
Date: Wed, 5 Dec 2012 09:28:48 -0800
Subject: Re: Event logging set to level 0. (filling the event log) [routingruleagent:404830]

From: jreed336
you need to turn off the diagnostics to stop the event log entries.
\\HKLM\System\\CurrentControlSet\\Services\\MSExchangeRoutingRuleAgent\\Diagnostics\\
Delete the General key and that should do the trick. You shouldn't have to do a restart from what I've seen.
Read the full discussion online.
To add a post to this discussion, reply to this email (routingruleagent@discussions.codeplex.com)
To start a new discussion for this project, email routingruleagent@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com